查看完整版本 : Has anyone managed to get TP-Link TL-WN821N to work ?

newsreader 2013-8-13 07:25 AM

Has anyone managed to get TP-Link TL-WN821N to work ?

Ubuntu  can  find the  receiver,  but  is probably  using  the  wrong  driver. It  cannot  get  connected  even when  the  router is  not  password  protected. I  searched   the  net  and  it  seems that TL-WN821N  is  not  supported  by  Linux  yet.

lohengrin 2013-8-13 02:15 PM

回覆 1# 的帖子

Have you checked this?
[url]https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsTP-Link#USB[/url]
Identify your chipset 1st. Probably, Atheros ar9170
then google something like "build ar9170 kernel module"

I did this for tp-link's wn727n before. Of course it's a different chipset from yours however.

柏林” 2013-8-13 02:55 PM

I use 721.

newsreader 2013-8-13 08:58 PM

Thanks  for  the  suggestion. I  can  use TL-WN321G  without having  to  download or  compile  anything.  I  have  spent more than  2  hours  on WN-821N and  still cannot  even  get  the  light  to  brink. Maybe  I'll  use  a live  CD  ubuntu   13  to  see  if  the  new  kernel  can  do  better.

newsreader 2013-8-16 11:03 AM

No  luck  with  13.04  either.  Someone  on  the  net  maintained  that  the  dongle works  out  of  the  box  on  Ubuntu 12.04,  which is  what  I  have. So  far, I  still  cannot  get  the  light  to brink  under  Linux both on  my  desktop  and the  notebook. It  works  just  fine under XP,  which  is  expected   since  it  came  with  the  windows  driver.

lohengrin 2013-8-17 01:06 AM

[quote]原帖由 [i]newsreader[/i] 於 2013-8-16 11:03 AM 發表 [url=http://www.discuss.com.hk/redirect.php?goto=findpost&pid=369537750&ptid=22302688][img]http://www.discuss.com.hk/images/common/back.gif[/img][/url]
No  luck  with  13.04  either.  Someone  on  the  net  maintained  that  the  dongle works  out  of  the  box  on  Ubuntu 12.04,  which is  what  I  have. So  far, I  still  cannot  get  the  light  t ... [/quote]
I found a solved case on 11.x by specifying not to use the obsolete ar9170 driver. http://ubunt>><<s.org/showthread.php?t=1775726



[url=http://m.discuss.com.hk][img=100,23]http://i1.hk/d/images/r10/mobile.jpg[/img][/url]

lohengrin 2013-8-17 01:08 AM

http://ubunt>><<s.org/showthread.php?t=1775726



[url=http://m.discuss.com.hk][img=100,23]http://i1.hk/d/images/r10/mobile.jpg[/img][/url]

lohengrin 2013-8-17 01:15 AM

[quote]原帖由 [i]lohengrin[/i] 於 2013-8-17 01:08 AM 發表 [url=http://www.discuss.com.hk/redirect.php?goto=findpost&pid=369593723&ptid=22302688][img]http://www.discuss.com.hk/images/common/back.gif[/img][/url]
http://ubunt>> [/quote]
keyword blocked. http://t.co/AV0TXkVZAD



[url=http://m.discuss.com.hk][img=100,23]http://i1.hk/d/images/r10/mobile.jpg[/img][/url]

lohengrin 2013-8-17 01:29 AM

[quote]原帖由 [i]lohengrin[/i] 於 2013-8-17 01:15 AM 發表 [url=http://www.discuss.com.hk/redirect.php?goto=findpost&pid=369594147&ptid=22302688][img]http://www.discuss.com.hk/images/common/back.gif[/img][/url]

keyword blocked. http://t.co/AV0TXkVZAD



[img=100,23]http://i1.hk/d/images/r10/mobile.jpg[/img] [/quote]
原來咁係觸犯板規,噢!



[url=http://m.discuss.com.hk][img=100,23]http://i1.hk/d/images/r10/mobile.jpg[/img][/url]

newsreader 2013-8-17 10:09 AM

Thanks.  I'll  look  into  that.

I  tried, still  no  luck.  The  green  light  stays  on  though I  can  see  the routers  on  the  screen. I'll  give  it  2  weeks  to  see  if  TP-link can  get  the  problem  solved. If  not, I'll  buy  another  802.11n receiver. This  time,  I'll  google before   I  buy.

[[i] 本帖最後由 newsreader 於 2013-8-17 03:51 PM 編輯 [/i]]
頁: [1]
查看完整版本: Has anyone managed to get TP-Link TL-WN821N to work ?